Tuesday, August 18, 2009

Early Android adopters


Were you an early Google Android adopter? If you have a T-Mobile G1 running Google Android, you may be sad to know that additional updates beyond Android 1.5 may not "fit" on your device. The G1 doesn't have enough internal flash memory for an updated operating system. That's not to say that people may not develop custom ROMs that may fit, but you should not expect any type of official release from T-Mobile or HTC.

Now that we have several new phones running Google Android, why keep the G1? Upgrade to a newer, faster phone. Then, you can repeat that upgrading process in 1-2 years. And repeat it again, and again, and again... (how many smartphones have you had in the last 2-3 years?)

No comments:

Post a Comment

Blog Widget by LinkWithin